FBK - YouTube Chat Integrations Disabled (HoloChats) – Incident details

System Under Maintenance

YouTube Chat Integrations Disabled (HoloChats)

Resolved
Operational
Started 7 months agoLasted 7 days
Updates
  • Resolved
    Resolved

  • Monitoring
    Monitoring

    Temporarily routing chat through my home network.

  • Identified
    Identified

    Upon some testing, there in fact seems to have not been a breaking change. The service works immediately from my home setup. YouTube instead seems to have pushed some more aggressive blocking of bots accessing chat. The bot has never been blocked from accessing chat before.

    This is more straightforward to work around, but is actually a worse situation in terms of this being likely to happen again and breaking other bots as well.

  • Investigating
    Investigating

    At the exact time on this incident, YouTube had pushed a change which disabled FBK's YouTube chat integration. Features which rely on this are no longer functioning at this time. The library FBK was using for chat was very reliable but was archived 4 years ago and will not be updated.

    I have unfortunately discovered this at the very end of my weekend here, so I do not know how long it will take to look into this. If this is a simple change I can adapt it to myself, then I may be able to address it during the week but otherwise I will need to evaluate the viability for another method of scraping YouTube chat.